Avalpa Community

The place where we can talk freely about Avalpa product and services
It is currently Mon Jun 27, 2022 1:33 am

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 8 posts ] 
Author Message
 Post subject: Bit Rate Issue
PostPosted: Mon Oct 07, 2013 2:02 pm 
Offline

Joined: Mon Oct 07, 2013 1:54 pm
Posts: 5
Hi,

I am facing the issue of bit rate...
Actually i have prepared TS file using tscbrmuxer tool.. now the problem is the bit rate what i given for DVB tables, audio file, video file and for applications in TS file is not same when i played the same TS file in dvb-s Dektec.
Andthe total output bit rate of TS file also changed when i played the TS file in DVB-S Dektec...

Pls suggest me to solve this problem....


Top
 Profile  
 
 Post subject: Re: Bit Rate Issue
PostPosted: Tue Oct 08, 2013 10:58 am 
Offline

Joined: Sun Sep 22, 2013 10:29 am
Posts: 39
please try to put the few relevant line of your script. it's not very clear to me what you are trying to do.

as you are looking to feed a DVB-S modulation, the total bit rate should be the net rate of the radio channel computed from the modulation values, of course (FEC S/R etc..)

bests


Top
 Profile  
 
 Post subject: Re: Bit Rate Issue
PostPosted: Tue Oct 08, 2013 1:28 pm 
Offline

Joined: Mon Oct 07, 2013 1:54 pm
Posts: 5
Hi

I have attached screen shots of Dektec(Named with shankar11.PGP) and screen shot of Linux terminal having tscbrmuxer tool with files(named with TSCBRMUXER.png)

In the screen shots i marked some parameters with red lines for clear understanding..
Now please refer the 1st image of TSCBRMUXER.png,
The tscbrmuxer tool generated Final_stream.ts file with final output bit rate of 46924bps
Pls see the bit rate of individual files containing in Final_Stream.ts(i.e firstnit.ts, firstpat.ts.. etc)

Now please refer the 2nd image of shankar11.JPG,
The same Final_Stream.ts TS file is played in Dektec(DTA-107S2),
Here you can observe the changes happen in total output bit rate and individual files bit rate
for example: total output bit rate showing in Dektec is 7,191,356bps but it was actually 46924bps
and for dvb tables bit rate also changed here.

Please help me to solve this problem..


You do not have the required permissions to view the files attached to this post.


Top
 Profile  
 
 Post subject: Re: Bit Rate Issue
PostPosted: Wed Oct 09, 2013 9:15 pm 
Offline

Joined: Sun Sep 22, 2013 10:29 am
Posts: 39
i see where the issue lie.
you don't put in the tscbmuxer command line the o:final_bitrate param, so they bitrate figure you actually put in b:xxx are just relative percentual of the single TS components.

as you can see, in the StreamXpress, provided the modulation params, you end up with a 7.191.356 bitrate per second.

if you want to match this figure in the tscbrmuxer you have to put a line as:

tscbrmuxer b:bitrate1 pat.ts b:bitrate2 pmt.ts b:xxx nit.ts ...... o:7191356 null.ts > Final_Stream.ts

this way the components will be inserted at the right proportion against the final bitrate of the channel.

hope it helps

andrea


Top
 Profile  
 
 Post subject: Re: Bit Rate Issue
PostPosted: Thu Oct 10, 2013 7:52 am 
Offline

Joined: Mon Oct 07, 2013 1:54 pm
Posts: 5
Hi

Thanks for the replay but still problem is not solved.
As u said, i prepared a TS file with o:7191356 null.ts as last parameter
and then played that TS file in stream express and again the same problem i faced.
This time difference of total output bit rate between stream express and TSCBRMUXER is very high.
Again i am attaching screen shot of these.


i marked with red lines in both screen shots where i am getting issues.

Pls suggest me to solve this problem
Thanks in advance.


You do not have the required permissions to view the files attached to this post.


Last edited by shankar on Fri Oct 11, 2013 10:34 am, edited 1 time in total.

Top
 Profile  
 
 Post subject: Re: Bit Rate Issue
PostPosted: Fri Oct 11, 2013 10:47 am 
Offline

Joined: Mon Oct 07, 2013 1:54 pm
Posts: 5
Hi Aventuri,

Thanks for the replay but still problem is not solved.
As u said, i prepared a TS file with o:7191356 null.ts as last parameter
and then played that TS file in stream express and again the same problem i faced.
This time difference of total output bit rate between stream express and TSCBRMUXER is very high.
Again i am attaching screen shot of these.


i marked with red lines in both screen shots where i am getting issues.

Pls suggest me to solve this problem
Thanks in advance.


You do not have the required permissions to view the files attached to this post.


Top
 Profile  
 
 Post subject: Re: Bit Rate Issue
PostPosted: Sun Oct 13, 2013 12:59 pm 
Offline

Joined: Sun Sep 22, 2013 10:29 am
Posts: 39
it's not clear to me how are you creating the file for feeding streamXpress.
is the output from tscbrmuxer directly written into a file?

who's doing the rate control here?

i suppose you need some proper professional service..


Top
 Profile  
 
 Post subject: Re: Bit Rate Issue
PostPosted: Mon Oct 14, 2013 6:54 am 
Offline

Joined: Mon Oct 07, 2013 1:54 pm
Posts: 5
Hi Aventuri,

Yes, The Final_Stream.ts file is created from tscbrmuxer tool
and then i copied Final_stream.ts file and played in another system which is having Dektec stream express.

And in tscbrmuxer tool i only assigning bit rate for Final_stream.ts
But when i played the same file in stream express bit rate is changing.

So pls help me.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group